eXtream Software Development Forum
Working good with one USB device but not another. - Printable Version

+- eXtream Software Development Forum (http://www.extreamsd.com/forum)
+-- Forum: Apps (http://www.extreamsd.com/forum/forumdisplay.php?fid=4)
+--- Forum: Audio Evolution Mobile (http://www.extreamsd.com/forum/forumdisplay.php?fid=21)
+---- Forum: Help (http://www.extreamsd.com/forum/forumdisplay.php?fid=10)
+---- Thread: Working good with one USB device but not another. (/showthread.php?tid=538)



Working good with one USB device but not another. - Bryan_Sw - 06-26-2017

Evolution is licensed with USB audio driver on a galaxy S5 with Android 6.01. Works fine with Native Instruments Komplete Audio 6 but needs to be attached to a USB powered hub as the phone won't provide acceptable power to the device. This setup works very well.

I tried a different USB audio device that has it's own external power. It 's a Boss GT-1 multieffect guitar processor pedal. It is recognized by Evolution as an USB audio device but fails to work with it. I cannot play or record anything with it hooked up. This probably isn't a bug with the software so I didn't put this in the forum area for "Bugs Found". I thought maybe I could run the GT-1 into the OTG cable and it would work too. I don't know why it wouldn't. I can use it directly with my DAW software on my laptop without any problem.

I will probably just try patching the GT-1 into my Komplete Audio 6 device and use it that way for now.


RE: Working good with one USB device but not another. - dwrae - 06-27-2017

The GT-1 is not USB class compliant and therefore does not work.


RE: Working good with one USB device but not another. - Bryan_Sw - 06-27-2017

I'll accept that as a reason.
Thanks