eXtream Software Development Forum
Recordings slows down - Printable Version

+- eXtream Software Development Forum (http://www.extreamsd.com/forum)
+-- Forum: Apps (http://www.extreamsd.com/forum/forumdisplay.php?fid=4)
+--- Forum: USB Audio Recorder PRO (http://www.extreamsd.com/forum/forumdisplay.php?fid=23)
+---- Forum: Bug reports (http://www.extreamsd.com/forum/forumdisplay.php?fid=15)
+---- Thread: Recordings slows down (/showthread.php?tid=656)



Recordings slows down - jiddish - 03-12-2018

Dear all,

I'm using this wonderful app to let participants make their own recordings from their homes for my research. My set-up is as follows:

- two shure xlr microphones
- one iRig duo
- moto C plus smartphone


After the recordings have been made, the files automatically get uploaded to Google Drive.

The problem we face at the moment is that some of the recordings are slowed down for some reason. Instead of a voice at normal speech rate we now hear a (robotic) voice at a slow speed rate.

Does anyone of you has any idea what could be the cause of this problem?


RE: Recordings slows down - dwrae - 03-12-2018

So you sometimes get good results and sometimes bad with the exact same equipment (not two different Moto C's for example)?


RE: Recordings slows down - jiddish - 03-13-2018

(03-12-2018, 04:51 PM)dwrae Wrote: So you sometimes get good results and sometimes bad with the exact same equipment (not two different Moto C's for example)?

Yes, exactly. All recordings are made on the same phone. For each speech task that the participants perform they start a new recording. Some of those recordings are perfectly fine whereas others are not. Could it perhaps be a memory/buffer issue?


RE: Recordings slows down - jiddish - 03-15-2018

I did some more research. It seems to happen especially during the last recordings of a recording session, while the first are always ok. Also, when one recording is corrupt, the following recordings will be corrupt as well unless the app is rebooted.

I've attached an excerpt of the logfile of one of the corrupt recordings. It looks indeed to a buffer issue since the line "Error 2 in advanceRecordBuffer 88, bytes = 704" comes up repeatedly.

Is this is an issue with the app (should I change the buffer size for instance) or is it an issue with the phone memory?


RE: Recordings slows down - dwrae - 03-16-2018

That looks like an error in the app. If it's easily reproducible, we can send you a version which outputs more debugging information.


RE: Recordings slows down - jiddish - 03-16-2018

Yes, that would be helpful! I can easily reproduce the error, I just have to make a bunch of recordings. Please send it to jimeel at gmail dot com.