eXtream Software Development Forum
unable to change the base dir - Printable Version

+- eXtream Software Development Forum (https://www.extreamsd.com/forum)
+-- Forum: Apps (https://www.extreamsd.com/forum/forum-4.html)
+--- Forum: USB Audio Recorder PRO (https://www.extreamsd.com/forum/forum-23.html)
+---- Forum: Help (https://www.extreamsd.com/forum/forum-12.html)
+---- Thread: unable to change the base dir (/thread-308.html)

unable to change the base dir - elopi - 04-20-2016

Seems a very common problem. I have a galaxy S5 mini with android 4.4.2. I tried to change the base dir for recordings. Following what the program says I created the following dir /mnt/extSdcard/Android/data/com.extreamsd.USBAudioRecorderPRO (note that the various file manager Galaxy apps does not allow me to create dir with capital letters, I had to detach the SD and create it in a PC with Win7).

No luck using either a path ending in com.extreamsd.USBAudioRecorderPRO or com.extreamsd.usbaudiorecorderpro or com.extreamsd. USBAudioRecorderPRO or com.extreamsd. USBAudioRecorderPRO (notice the space between the dot and USB, as appears in the original default

Your app always says: "you must select a directory ending with USBAudioRecorderPRO or create a new one" or "error creating Recordig directory"

Now I'm stuck. I have a 128GB SD card and cannot use a single bit of it. Isn't just an aestethic problem...


RE: unable to change the base dir - dwrae - 04-21-2016

We just tried on a S5 and it worked fine. We created a folder com.extreamsd.usbaudiorecorderpro using the s5's own file manager in /mnt/extSdcard/Android/data and selected that folder (not in /storage/... !) in UARP and let it create the USBAudioRecorderPRO there. If you try again, please remove USBAudioRecorderPRO folder if you created it yourself.

RE: unable to change the base dir - elopi - 05-01-2016

OK it worked also for me. The key was to use the original S5 Archive application (doesn't work with ES file manager, Root browser and similar). Thanks

RE: unable to change the base dir - elopi - 05-18-2016

I was too optimistic. There was no error when selecting the directory on the external SD (the only path which gave no error was /mnt/extSdCard/Android/data/USBAudioRecorderPRO) but when pressing the record button the following message arose: "Error opening a file for recording!" followed by "Failed to start recording". And obviously, no recording...