Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Playlist issue with FiiO M11 Plus LTD
Big Grin 
Sorry for the long post, but I thought it best to give as much information as I could to see if anyone can help.  Thanks for taking the time to read through to the end. Confused

I first installed UAPP on my FiiO M11 Plus LTD in Oct. 2021.  Since there were no instructions on how to import playlists into UAPP, I contacted the developers.  Davy W. responded and gave me the information I needed.  At that time, I wrote detailed instructions for how to do it.  I've been using my FiiO regularly for the last 16 months adding new music and deleting and importing updated playlists using those instructions.

A couple of weeks ago, I had a major malfunction on the FiiO that required a full factory reset.  After the reset, I also got an upgrade notice for Android 10 build 1.0.8 and upgraded.  I installed all my apps, including UAPP, from the Google Play Store and reloaded my music collection.  Everything was going well until I tried importing all my playlists back into UAPP.

I've now spent over a week trying to get them back into UAPP.  Using the instructions that have worked previously isn't working now and I can't figure out why.  While UAPP recognizes the file and indicates that it's processing the correct number of tracks as it normally would, the end result is always a playlist with no tracks.

I use Windows 10 and MediaMonkey to manage my music collection and export my playlists as M3U files.  I edit each M3U to replace the path of the tracks from my home network (H:\Music) to that of the FiiO (/storage/external_sd/Music).  I also change all \ to / and the EOL character to a Linux newline.  I use ADB from the Android SDK to transfer the files to /storage/emulated/0/UAPP/Playlists on the FiiO.

I know UAPP recognizes, at least, 2 different formats for imported M3U files.
Format 1:
#EXTINF:243,Aerosmith - Remember (Walking In The Sand)
/storage/external_sd/Music/Aerosmith/Night In The Ruts/Remember (Walking In The Sand).flac
#EXTINF:258,Aerosmith - Dude (Looks Like A Lady)
/storage/external_sd/Music/Aerosmith/Permanent Vacation/Dude (Looks Like A Lady).flac

Format 2:
/storage/external_sd/Music/Aerosmith/Night In The Ruts/Remember (Walking In The Sand).flac
/storage/external_sd/Music/Aerosmith/Permanent Vacation/Dude (Looks Like A Lady).flac

I know that M3U files copied from Windows to the FiiO with ADB are modified somehow during the transfer to insert 2 unknown hex characters at the beginning of the file and they have to be deleted before UAPP will recognize the file.

I also installed UAPP on my Galaxy S21 with Android 13.  I picked a playlist with only a few tracks and built a Music directory with only those tracks on the phone.  My import playlist instructions worked perfectly on the first try.  Aaaaaaahhhhh !

Back on the FiiO, I've tried all of the following in every combination:
- making test M3U files with only a few tracks that can be quickly edited
- both formats of M3U
- UTF-8, UTF-16, ASCII and IBM437 character encoding
- Windows, Linux & Mac EOL
- editing the raw M3U file in Windows using Notepad++
- editing the raw M3U file in FiiO OS using OldSchoolEditor app

Since I had no trouble before the reset and reinstall, it seems that the new problem is probably due to either the Android upgrade or the new version of UAPP installed from the Google Play Store.  Any help that anyone can provide would be MUCH appreciated.

Messages In This Thread
Playlist issue with FiiO M11 Plus LTD - by GrumpyOldMan - 03-06-2023, 03:16 AM

Forum Jump:

Users browsing this thread: 1 Guest(s)