Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Playlist issue with FiiO M11 Plus LTD
Big Grin 
Sorry for the long post, but I thought it best to give as much information as I could to see if anyone can help.  Thanks for taking the time to read through to the end. Confused

I first installed UAPP on my FiiO M11 Plus LTD in Oct. 2021.  Since there were no instructions on how to import playlists into UAPP, I contacted the developers.  Davy W. responded and gave me the information I needed.  At that time, I wrote detailed instructions for how to do it.  I've been using my FiiO regularly for the last 16 months adding new music and deleting and importing updated playlists using those instructions.

A couple of weeks ago, I had a major malfunction on the FiiO that required a full factory reset.  After the reset, I also got an upgrade notice for Android 10 build 1.0.8 and upgraded.  I installed all my apps, including UAPP, from the Google Play Store and reloaded my music collection.  Everything was going well until I tried importing all my playlists back into UAPP.

I've now spent over a week trying to get them back into UAPP.  Using the instructions that have worked previously isn't working now and I can't figure out why.  While UAPP recognizes the file and indicates that it's processing the correct number of tracks as it normally would, the end result is always a playlist with no tracks.

I use Windows 10 and MediaMonkey to manage my music collection and export my playlists as M3U files.  I edit each M3U to replace the path of the tracks from my home network (H:\Music) to that of the FiiO (/storage/external_sd/Music).  I also change all \ to / and the EOL character to a Linux newline.  I use ADB from the Android SDK to transfer the files to /storage/emulated/0/UAPP/Playlists on the FiiO.

I know UAPP recognizes, at least, 2 different formats for imported M3U files.
Format 1:
#EXTINF:243,Aerosmith - Remember (Walking In The Sand)
/storage/external_sd/Music/Aerosmith/Night In The Ruts/Remember (Walking In The Sand).flac
#EXTINF:258,Aerosmith - Dude (Looks Like A Lady)
/storage/external_sd/Music/Aerosmith/Permanent Vacation/Dude (Looks Like A Lady).flac

Format 2:
/storage/external_sd/Music/Aerosmith/Night In The Ruts/Remember (Walking In The Sand).flac
/storage/external_sd/Music/Aerosmith/Permanent Vacation/Dude (Looks Like A Lady).flac

I know that M3U files copied from Windows to the FiiO with ADB are modified somehow during the transfer to insert 2 unknown hex characters at the beginning of the file and they have to be deleted before UAPP will recognize the file.

I also installed UAPP on my Galaxy S21 with Android 13.  I picked a playlist with only a few tracks and built a Music directory with only those tracks on the phone.  My import playlist instructions worked perfectly on the first try.  Aaaaaaahhhhh !

Back on the FiiO, I've tried all of the following in every combination:
- making test M3U files with only a few tracks that can be quickly edited
- both formats of M3U
- UTF-8, UTF-16, ASCII and IBM437 character encoding
- Windows, Linux & Mac EOL
- editing the raw M3U file in Windows using Notepad++
- editing the raw M3U file in FiiO OS using OldSchoolEditor app

Since I had no trouble before the reset and reinstall, it seems that the new problem is probably due to either the Android upgrade or the new version of UAPP installed from the Google Play Store.  Any help that anyone can provide would be MUCH appreciated.
Before we will look at the log file, what happens if you select Folders, then browse to the folder containing the M3U file and tap on it? So, not using Library, but Folders?
(03-07-2023, 12:56 PM)dwrae Wrote: Before we will look at the log file, what happens if you select Folders, then browse to the folder containing the M3U file and tap on it? So, not using Library, but Folders?

It shows the Parsing Playlist counter, but doesn't ask to create a playlist.  The Library and Playlist views are empty.  Back in the Folder view, adding M3U to the Queue creates a single entry with M3U file name, but no tracks.  Clicking on this entry gives a failed to play message.

I manually created a playlist directly on the FiiO while in UAPP, exported it to an M3U, switched to Folder view, found the M3U and clicked it.  I got a Parsing Playlist counter, then a list of the tracks in the M3U file, but no request to save the playlist.  As long as I stay in the Folder view, the tracks can be played individually from the list, each can be added to the queue, and all show in and can be played from the queue when switching to the Queue view.  However, leaving the Queue view erases everything from all views until using the Folder view to find the M3U file again.
I'm afraid the only way to make sense of this is if you can send a M3U to and then we will handle it further there.
Thank you !  I'll send labeled versions of each M3U I've tried.
As I was preparing to send in a problematic playlist to as per the above request in this thread, I decided to start fresh by deleting all exported playlists I currently had on both the FiiO and PC.  I also did a deep dive into all the settings available in MediaMonkey where I found that I could totally eliminate the need to edit the M3Us exported by automatically changing the path, encoding and EOL to Unix/Linux format.

I copied the newly exported M3U to the UAPP Playlists folder on the FiiO.  When I started UAPP, I found the M3U in the Playlist view as a Read-Only and clicked on it.  UAPP parsed the playlist and asked me if I wanted to save it in UAPP format.  I clicked OK and then clicked on the newly created playlist.  Much to my surprise, it opened a list of tracks as it should.  The tracks can be played directly, added to the queue or added to another playlist.  Best, they don't disappear, as before, when moving to the Library or other views.

I compared this new exported M3U to a previously edited version of this same M3U to see why the new one worked and the old didn't, but I couldn't finding a single character difference !  I'm at a total loss as to why it's now working and for over 2 weeks it didn't.  However, while I can finally import M3U playlists again, all is still not perfect.

I've now imported 62 M3U playlists into UAPP and discovered that 20 of them are missing tracks once on the FiiO.  I'm slowly going through each UAPP playlist to identify what tracks are missing, then determining why.  While a few were due to issues in MediaMonkey, many were dropped when parsed by UAPP because the track name included letters with diacritical marks such as those in Piña, Für and Coppélia.  I have yet to determine the cause for several other track names without obvious issues.  However, in every case, I was able to manually add the tracks to the playlist they were missing from using the Tracks view.

Overall, while the main playlist issue I was having has been resolved, there are still some minor issues that require work-arounds to fully utilize the UAPP playlist feature.

Forum Jump:

Users browsing this thread: 1 Guest(s)