Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
"Async in progress" problem and songs not playing
Hello everybody,

I have the following problem.

I changed my smartphone from a LG V30 to a Samsung Galaxy S23+ and copied all my music folders from the V30 to the Galaxy S23+. At this time I also ripped three more CDs with Exact Audio Copy as flac files and copied them as well to my new phone. When I tried to play these newly added albums 2 of the 3 wouldn't play. The other one plays just fine.
When I try to play the song from the library and tap the song to play, nothing happend, and if I tap rapidly on the song I get a pop up that says: async in progress. But then nothing happens.
While trying other albums I also find an album that wasn't newly ripped and was just copied from my old phone to the new, which also ddid't work. It played normaly on my LG V30.
Funnily enough when I try tp play the songs via folders and not the Library tab I can play the song just fine. 
Copied the newly ripped albums to my old phone and the song also play just fine on my LG V30 via the Library.
I re-ripped the albums but this didn't help.
Also tried other players insted of UAPP and all played the songs just fine from their library tab. 
I was already in contact with the support but in spite of their efforts we couldn't find a solution. 
So, I was just thinking that I ask here as well and maybe someone else has or had the same problem and maybe found a solution, which they can share.
We already came to the conclusion that the FLAC files have errors in them, even according to the original FLAC test utility. So although other players may skip errors, UAPP (or actually FFmpeg in the mode where it uses custom read/seek functions as used in scoped storage mode) does not.

If you only have FLAC files, you could enable the new option 'Force non-scoped storage' in the app's Library settings and then clear and rescan the Library. Please note that this will skip files that are not known as 'media' files to Android, so it won't scan DSD files etc. If you solely have FLAC files, this shouldn't be a problem.
Yes I know that you tested one file and it had errors in it according to the test utility. That's why I copied the cd again with the newest version of exact audio copy and their test utility and the program audiotester (which is linked on the flac website) found no errors. 
But the files still didn't play via the library on my Galaxy S23 but the played just fine on my Lg v30 with UAPP on the newest version. Even the files which had errors before played fine on the v30 with uapp.
So it doesn't seem like that uapp can't handle the files, but that there is something else that's preventing the files to be played on my S23 via uapp.

I will try the "Force non-scoped storage" option

Forum Jump:

Users browsing this thread: 1 Guest(s)