Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
UAPP on FiiO X5 3rd gen-distorted output internal Android Mode
I installed UAPP on my FiiO X5 3rd gen (w/1.1.9 fw) and ran it just using internal Android mode (no outboard DAC) and when I try to stream Tidal or play any local file all I get is a hashy 100% digital distortion, like the FiiO just can't process whatever UAPP is sending it.

I haven't had a chance to try it yet in USB to DAC mode but will soon.

I'm thinking that it should work in no-DAC mode in the FiiO just using internal Android but my gut tells me there may be an incompatibility of some kind. I think there are others that have gotten the X5III working with UAPP but they're probably using the intended USB to DAC mode.

I don't know what the problem is in my case unless the X5 will simply need to be run in full outboard DAC mode. Any advice appreciated!
Yes, FiiO refuse to implement the 32-bit floating point which is a standard feature on Android 5 and higher. So you need to enable 'Force 16-bit' or send us an email at asking for our beta hires driver which supports the FiiO X5iii.
The Force 16-bit worked--sounds fine now. Thanks.
(01-28-2018, 07:16 AM)BobSmith8901 Wrote: The Force 16-bit worked--sounds fine now. Thanks.

Thanks to extreamsd for the update to the program--version 4.1.6. Once my X5 III upgraded to the new iteration it automatically recognized the internal DAC and put the driver setting at the Hi Res driver. Sounds fantastic and the new interface is great!
Thank you for all of your hard work!

Forum Jump:

Users browsing this thread: 1 Guest(s)